Thumbnail Generation Error

After updating to 3.5 today, whenever I launch the program with thumbnail generation enabled, it simply repeats the process over and over, seemingly accomplishing nothing except making the “thumbnail_generation.txt” logfile larger each time. This renders the program entirely unusable, as the thumbnail generation window will open constantly whenever the program is in focus. Letting it run for over a dozen consecutive times resulted in no change, and I have already attempted a clean install, including completely removing everything in the FW-Sim folder in Documents, which resulted in nothing changing.

Once thumbnail generation is disabled everything works fine other than not having any thumbnails for effects, however.

1 Like

Thanks for the notice, let me look into it!

First, do you have custom effects on your computer, or only the standard effects?

Second, as an experiment - what happens when you try this:

  1. Close FWsim
  2. find the folder Documents → FW-sim and rename it to “FW-Sim backup”
  3. try starting FWsim again

Does the problem still happen if you do it that way?

1 Like

I tried to do that and it didn’t work initially, but the problem has stopped happening and I’m not sure what exactly I did to fix it. I did notice the user.xml file went from 16KB to 15KB, although this didn’t happen when I first tried this fix. Either way it works completely fine now as far as I can tell.

1 Like

Thank you, good to hear. If the problem re-appears, just let me know.

1 Like