FWsim 3.5 Beta Feedback

I need a help!!
https://community.fwsim.com/t/fwsim-not-opening-in-my-pc/642/2
@Lukas

1 Like

Hey,

thanks for posting. We re-programmed the entire color processing. Unfortunately, this means we cannot guarantee the exact same look that we had before the changes.

One thing I notice on your screenshot is that there is no glow. Please try setting the graphics quality to Medium (instead of Low). Then, please check in the Preferences under “Graphics” that the Glow is set to more than 0%.

What happens when you make these changes and look at your scene with glow activated? Does it look more like you want it then?

I just checked, and it works on my computer. Two questions:

  1. Which version are you using?
  2. Could you send me an email with your effect file?

Thanks for posting, I just responded there.

1 Like

I’m using the most recent version! I created 2 effects and they both did the same thing! How can I send you the effects?

Thanks for your tip.
I checked the graphics quality and it is set to High. The screenshot shows the results with the glow set to 50%.


I also tried it with glow set to 100% and the results were similar, just a little brighter.
It might be hard to tell with the quality of the screenshots, but to me it looks like a very slight improvement. I suspect the glow is covering some of the color shifting and making it appear more golden, but the colors of the tail particles themselves are still off.
Also, the effect files shown in these screenshots are not my own; these are the included effects that came with the simulator package I downloaded for the previous 3.4 version. I have not modified them in any way, other than size.
In addition, I took both of these screenshots with the 3.5.0.5 version of the simulator. I have since updated to the latest version, 3.5.0.9, and the color shifting is still apparent, if that’s helpful.

1 Like

@Jpyro35 Thanks for the comprehensive report. Please try updating again to version 3.5.0.10. There is now a “Contrast” slider in the Preferences, under “Graphics”. Please try using that slider, and dragging it towards the left. Do the graphics now look better to you?

1 Like

Every time i push the play button, fwsim shuts down. version 3.5.0.10

Edit: i found the failure, after the update my vulcanos did not work anymore, i deleted them and now fwsim runs fine!

1 Like

Thanks Henrik, this problem should be resolved in 3.5.0.12 which was released yesterday.

Best Regards,
Lukas

2 Likes

ok, fwsim update says me, i have the neweset version 3.5.0.10

1 Like

Please try clicking Help → Check for Updates. FWsim should then update to version 3.5.0.12.

1 Like

thats what im doing, but it says i have the newest version.

1 Like

My apologies! We didn’t release the update for FWsim Pro Beta yet. It will be available shortly, please check again in half an hour. (edit: The update is available now)

2 Likes

Thank you for your help.
I have adjusted the contrast slider to the left and the results are definitely improved. While I have to drag the slider almost all the way to the left to get it looking good, the brocades and willows no longer appear to have red tail particles. I found my favorite combination for Contrast and Glow to be 0.60 and 70%, respectively. This screenshot shows my display with these settings:


This is with version 3.5.0.13.
Overall I think this is a major improvement. The red tail particles still show up once the contrast slider gets past about 0.80, but anywhere to the left of that appears fine to me.
I was going to mention that the background becomes very bright when the contrast is set very low, however I then remembered the “Background Brightness” slider in Scenery and adjusted that to compensate (after taking the screenshot).
I then did an experiment where I set contrast all the way down (0.50) and Background Brightness also all the way down (0.10) to see if the red tail sparks came back when I did that, which they did not.
The only potential problem I see is that it seems that adjusting the Contrast slider darkens or lightens both the background image and the ground itself, but adjusting the Background Brightness slider does not. The result, with my current settings (Contrast 0.60, Glow 70%, Background Brightness 0.62) is the background image being dark but the ground being lighter, which looks weird. Perhaps making it so that the Background Brightness slider also adjusted the brightness of the ground would fix this? Just a thought.
Thank you again for your help, and I hope this is helpful to you.

1 Like

since the last update (FwSim 3.5.0.19), when I remove an effect FwSim crashes. for now I can no longer work on my New Years show

1 Like

@Jpyro35 thanks for your comprehensive report!

@GagnonSimPyrotechnic Thank you, there is a bug in FWsim Pro Beta 3.5.0.19. It will be fixed in about 20 minutes with update .20.

2 Likes

You should try bringing down the 3D World brightness option too, that will probably solve the problem of the ground being lighter! Anyways, happy New Year to you!

In Version 3.5.0.21 there is no positioning bar when it is on a point.

3 Likes

So, after i had now two monitors, it would be cool to have the options to open windows, like the single shot button effect window. cause it defenitly brings a bad taste to open and close thise window any time, it also would be cool to make an own window about the timeline…c that would be more interesting and i think ait would be a better way to work with fwsim :wink:

1 Like

Thanks. If you use FWsim Pro, there is actually a multi monitor mode. (But it is limited in its layout, you cannot customize the layout). Have you tried that multi monitor mode? Is it useful?

1 Like

Is anyone else having an issue where when you open FWsim, it crashes immediately 5 seconds after opening? Because I’ve been using the FWsim steam version for months and I haven’t had an issue with it since recently, I also got the creative version to see if maybe it was just an issue with steam but the creative version also does the same this. I sent a crash report about this situation as well.

1 Like

Thanks for reporting, and welcome to the FWsim community forum.

Can you send me your email address (that you entered when submitting the error report) via private message? Then I can look up your error report and check if this is already fixed.

EDIT: I received your email, thank you. It looks like you have a strange configuration with folder permissions on your Windows user account. I’ll help you resolve that via email.

1 Like